Configurez le réseau

De Wiki LOGre
Aller à : navigation, rechercher


WARNING : Ca parait bête si si vous vous trompez dans cette configuration... vous êtes mal :)

Configurez le réseau Ethernet

Editer le fichier /etc/config/network avec vi par exemple

IP statique (ex avec une Freebox V6)
  • Modifier le fichier comme suit:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static' ! IP statique
option ipaddr '192.168.1.1' ! IP de la Pbox
option netmask '255.255.255.0' ! Masque C
option gateway '192.168.1.254' ! IP du routeur
option dns '192.168.1.254' ! IP du routeur s'il fait relais DNS
  • Si vous avez un problème de connexion essayez de remplacer la dernière ligne par : (DNS google)
 list dns '8.8.8.8' 

Ca a marché pour moi.

IP dynamique
  • Modifier le fichier comme suit:
config interface 'lan'
       option ifname 'eth0'
       option proto 'dhcp'

Configurez le réseau Wifi

Editer le fichier /etc/config/wireless avec vim par exemple

En tant qu'Access Point ouvert
  • Modifier le fichier comme suit:

config wifi-iface option device radio0 option network wifi option mode ap option ssid PirateBox option encryption none

       option disabled 0
En tant que client Wifi
  • Modifier le fichier /etc/config/wireless comme suit:
config wifi-device  radio0
       option type     mac80211
       option channel  'auto'
       option hwmode   11ng
       option path     'platform/ar933x_wmac'
       list ht_capab   SHORT-GI-20
       list ht_capab   SHORT-GI-40
       list ht_capab   RX-STBC1
       list ht_capab   DSSS_CCK-40
       option htmode   HT20

config wifi-iface
       option device   radio0
       option network  wwan
       option mode     sta
       option ssid     logwifi
       option encryption psk2+aes
       option key      tototata
  • Et le fichier /etc/config/network en ajoutant:
config interface 'wwan'
       option proto  'dhcp'

Prise en compte des changements

Une fois ceci fait, pensez à relancer le script d'init du réseau :

/etc/init.d/network restart

Configurer un serveur dhcp basique sur l'interface wifi

Editer /etc/dnsmasq.conf et rajouter :

dhcp-authoritative
dhcp-range=wlan0,192.168.1.50,192.168.1.150,12h

Une fois la modification effectuée, relancer le script d'init :

/etc/init.d/dnsmasq restart

Note : il est préférable de garder une ip fixe pour le réseau ethernet, afin de ne jamais perdre la box ;)